Disable autocompletion with "." key in debugger

I am having an issue with the Python Debugger and confused how it interacts with the general editor settings.

I have disabled autocompletions (as well as accepting autocompletions with tab and enter)

However, when I use the debug console, I will still receive autocompletions. Interestingly, they cannot be accepted with tab or enter. Instead, they are accepted when I type the “.” (period) key.

Is there anyway to disable this? It is incredibly annoying to have the top auto-correct accepted everytime I type “.” (which I often need to call other methods)