[Nova 11b1] GitHub asking for password

  • my GitHub account works fine in Nova 10
  • in Nova 11b1 it asks for password?
  • nothing I enter here works (ie. my actual user/pass)
  • I have also tried removing and re-adding the account, still no joy

Screen shot 2023-04-17 at 13.45.21

Entering Personal Access Token (classic), which is the same one for Git Accounts settings of Nova, in the Password editbox resolved the issue for me.

I’m confused why it’s needed if Nova 10 is working OK with my setup?

Same here, although clicking Save in Keychain doesn’t seem to actually save it in the Keychain. Next time I load Nova 11 it asks again.

I ran into a similar (but different) keychain-related issue in nova 11. I think it has to do with the fact that the beta app is seen as a separate distinct app by Keychain—at least as far as access control is concerned—so a credential previously saved to keychain may be unusable by the beta app.

Perhaps the reverse might be true too (i.e. beta app saving entries under the main app’s identifier) …? But I haven’t run into that issue.

I don’t have much experience with APIs available to macOS apps so I’m just speculating based on observations.

Hello folks,

Would you all mind testing your findings in Nova 11b2, which was released this afternoon? I believe I’ve resolved some issues with Git services and Keychain that were inadvertently introduced.

1 Like

So far so good. In Beta 2 I was asked my for my Github credentials on the first Push, entered them and opted to ‘Save in Keychain’, and haven’t been asked again since, even after closing and re-opening the app. :+1:

Just tried Beta2 and am still getting the EOF error after entering creds for a repo (Beanstalk). Do I need to delete any prefs from Beta1 (and if so, where and what)?

It’s now working for me. Didn’t even asked for password.

Uninstalled all versions of Nova and installed Beta2. Working well now.