Unable to upload new extension version

I’ve uploaded v0.1.0 of my extension uk.eskola.shfmt, however it appears to be listed on the extension site as v1.0.0, this means firstly that it is always shown in the app extensions window as needing an update, and secondly that I cannot upload v0.2.0 because this is supposedly older than the existing version.

I also tried uploading a version named 1.1.0 instead of 0.2.0, but this gave the error that this version already exists. (HTTP 4xx error.)

These versions are being defined in extension.json, as documented.

I don’t know if this is also related, but on the extension page other fields from extension.json do not display correctly — e.g., repository and bugs. (Repository is not shown at all, Bug Reports is a link to https://). However, the license is being shown correctly.

Could it be that there’s a formatting error in the manifest file maybe? (Though I’d expect Panic to catch that in the upload…)

This is what I’m puzzled by, yes — upload was permitted, but seemingly not properly interpreted (and even required fields appear to have been ignored; both bugs and categories, at least).

I had also copied the manifest from a known-good one as a starting point and validated the JSON syntax before uploading.


Thank you for the report. We’re investigating what might be going on with the extension. I can confirm that the server did receive your original payload as 0.1.0 but seems to have incorrectly parsed it as 1.0. I hope to have more information soon.

1 Like


After investigation from our lead web engineer, we think we have solved the issue causing issues with submitting new extension versions. We’ve manually adjusted your extension’s current version to the proper 0.1 expected from its bundle, and you should now be able to submit updates with 0.2 (or 1.1) going forward.

If you still see issues after this, please let us know and we can continue investigating!


1 Like

Looks like that’s solved it, thanks!

1 Like